TS Startprozeduren bei Startproblemen

  • Der TS ist ja, wie wir alle wissen, manchmal zickig und manchmal wie eine Diva.


    -Man hat ein Szenario, und es will nicht mehr starten, obwohl es am Tag (oder Stunden) davor lief

    -Es wurden ein paar letzte Feinabstimmungen vorgenommen, und nun will das Szenario nicht mehr starten

    -Manche, gerade aufwendige Szenarien (Wie in meinen Fall die Reloaded) möchten auch nicht sofort starten.


    Durch Zufall und durch testen habe ich ein paar Startprozeduren gefunden, mit denen Szenarien, die bei direkten Start

    (TS start, Szenario wählen, Szenario starten)

    nicht starten wollen.


    Diese kosten zwar etwas Zeit, aber wenn es dafür am Ende funktioniert.................


    Hier ein paar Möglichkeiten, die in 3 von 4 Fällen funktionieren.


    -Generell vorher den Cache leeren

    -Wer ganz sicher gehen will, löscht die beiden SDB-Dateien im Pfad "DEIN LAUFWERK"\steamapps\common\RailWorks\Content von Hand.


    So wird die Szenarien/Strecken Datenbank neu erstellt.


    Möglichkeit 1 (Etwa 2 Minuten dauer)

    -TS Starten

    -Im Schnellen Spiel die Strecke und den Spielerzug (Oder ähnlich) wählen, der auch im Szenario fahren soll, dabei die GESAMTE Strecke laden lassen, inkl. gleicher zeit und gleichem Wetter

    -Falls erforderlich, den Zug Aufrüsten

    -Nach dem Aufrüsten 2 Minuten warten, dann das Szenario beenden

    -Nun direkt das gewünschte Szenario starten


    Möglichkeit 2 (Etwa 2 Minuten dauer)

    -TS Starten

    -Im Schnellen Spiel die Strecke und den Spielerzug (Oder ähnlich) wählen, der auch im Szenario fahren soll, dabei die GESAMTE Strecke laden lassen, inkl. gleicher zeit und gleichem Wetter

    -Falls erforderlich, den Zug Aufrüsten

    -Nach dem Aufrüsten nach 10 Sekunden in 2Sek Takt alle Ansichten (1-9) einmal aufwärts, einmal abwärts (9-1)durchschalten

    -Nach erreichen der 2 Minuten das Szenario beenden

    -Nun direkt das gewünschte Szenario starten


    Möglichkeit 3 (Etwa 3 Minuten dauer)

    -TS Starten

    -Im Schnellen Spiel die Strecke und den Spielerzug (Oder ähnlich) wählen, der auch im Szenario fahren soll, dabei die GESAMTE Strecke laden lassen, inkl. gleicher zeit und gleichem Wetter

    -Falls erforderlich, den Zug Aufrüsten

    -Nach dem Aufrüsten 2 Minuten warten, dann das Szenario beenden

    -Im Editor das gewünschte Szenario klonen, das Original NICHT löschen, den Klon NICHT umbenennen (Kopie von............Szenarioname)

    -In der Auswahl den Klon starten


    Wie oben erwähnt, funktioniert es bei mir in 3 von 4 Fällen.

    Und was sind schon 3 Minuten, wenn man dafür dann ein Szenario, in dem Wochenlange Arbeit drin steckt, am ende doch funktioniert?



    *Ergänzung bzgl Sound: Um nicht im Szenario plötzlich ohne Ton dazustehen (Ich nutze eine USB-Soundbar) habe ich das Intro-Video und den Menüsound aktiviert.

    Klingt zwar nicht so toll, aber, wenn beides Sound hat, ist auch im Spiel der Sound da.

    Einmal editiert, zuletzt von NCC1701E () aus folgendem Grund: Ergänzung bzgl Soundproblemen

  • Ich habe gerade im Rail-Sim-Forum einen anderen Tipp gelesen, der wohl aus einer TS-Seite in Tschechien stammt:


    Es wird auch beschrieben (Was bei mir zutrifft) das es hilft, wenn Szenarien mehr als 7,5GB RAM benötigen)


    -Freies Spiel starten (evt. auf der geplanten Strecke, das wird nicht erwähnt) und da etwas rum fliegen (Ich mache das die 2 Minuten)

    So bläht sich der Speicher auf (Bzw der TS glüht wie ein alter Diesel vor)

    -Beenden un dann das Szenario starten.


    Hat in 4von4 Fällen geklappt (Bei 4 Tests) von einen Szenario, welches den direkten "Kaltstart" verweigert hat.

  • Hier das ganze mal als Video.


    Gezeigt wird die Startprozedur mittels "Freien Spiel".


    Der erste Startversuch endet bei 1.09 im Crash, dann kommt die Startprozedur und zack, Szenario läuft.


    Einmal editiert, zuletzt von NCC1701E ()